Mono support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Mono Support profile/username folder 

Viewed 7903 time(s), 5 post(s) 12/11/2010 5:43:04 AMby nzgrub
nzgrub
1

nzgrub 12/11/2010 5:43:04 AM

when a person registers shouldn't there be a profile/username folder created. Or where can the user go for there own page, link to friends etc.
This content has not been rated yet. 
62 Reputation 10 Total posts
denis
2

denis 2/15/2011 12:49:49 PM

Yes, each registered user automatically gets a profile page with the URL in the following format (this can be changed via configuration settings). See the list of users in the bottom right corner of this page for an example: http://monox.mono-software.com/MonoX/Pages/SocialNetworking/Dashboard.aspx
This content has not been rated yet. 
7147 Reputation 932 Total posts
nzgrub
3

nzgrub 12/11/2010 5:47:34 PM

My install is not creating any users folder, even the sample pages do not have any user folders. see http://www.youth.net.nz/social/MonoX/Pages/SocialNetworking/Dashboard.aspx
This content has not been rated yet. 
62 Reputation 10 Total posts
denis
4

denis 12/11/2010 8:39:03 PM

Hi,
I assume that you are using IIS 6. Since the profile Web parts (and many others) are using the "rewritten" URLs - they do not have the .aspx extension - you need to set the "wildcard mapping" in IIS so it could catch all requests, including the ones for "extensionless" resources. This feature is crucial for SEO and many other techniques. In IIS 7 and higher this can be set via web.config.

By default, only the .aspx and related files (.ashx, .asmx) are mapped to the ASP.NET runtime. You can change this by following this procedure:
- right click on the Web site you want to administer, Properties, Home directory tab, Configuration button. Copy the executable path from one of the existing ASP.NET extensions (.asax, for example). Click on the insert button, paste the executable path you copied in the previous step, and uncheck "Verify that file exists". This should fix this problem. More details: [url=http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/5c5ae5e0-f4f9-44b0-a743-f4c3a5ff68ec.mspx?mfr=true]http://www.microsoft.com/technet/prodtechnol/WindowsServer2003/Library/IIS/5c5ae5e0-f4f9-44b0-a743-f4c3a5ff68ec.mspx?mfr=true[/url]

It is important to note that these are not actual file system folders, although the URL format can be deceiving. ASP.NET and MonoX gives you a total freedom over the URL formatting.
This content has not been rated yet. 
7147 Reputation 932 Total posts
cosmogonor
5

cosmogonor 3/11/2011 7:56:45 AM

Please look into this issue

This content has not been rated yet. 
1176 Reputation 140 Total posts