Mono support board

Start the conversation, ask questions and share tips and solutions with fellow developers.

Non-registered users can only browse through our support boards. Please register now if you want to post your questions. It takes a second and it is completely free. Alternatively, you can log in without registration using your credentials at major sites such as Google, Microsoft Live, OpenId, Facebook, LinkedIn or Yahoo.

Mono Support SecurityException during Install 

Viewed 8798 time(s), 3 post(s). 3/18/2012 11:32:09 AMby rugby
rugby
1

rugby 3/18/2012 11:32:09 AM

Hi

I am installing the latest version of MonoX on the fowlloing platform for which I have total control,

Windows 2008 R2 server
MSSQL 2008 R2IIS 7.5
.NET 4.0

I have followed guide in manual and on this web site. I have set all permissions to Network Service for both files/folders and Application in IIS. When browsing to the install I receive this error (after truning off custom errors):

Stack Trace:

[SecurityException: That assembly does not allow partially trusted callers.]
MonoSoftware.MonoX.BaseHttpApplication..ctor() +0
ASP.global_asax..ctor() +9

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET
Version:4.0.30319.272

I have searched around and can't find a solution to it.

Any help would be greatly appreciated.

Thanks


This content has not been rated yet. 
30 Reputation 2 Total posts
rugby
2

rugby 3/18/2012 3:47:56 PM

Hi

After searching around I discovered this link http://superuser.com/questions/38476/this-file-came-from-another-computer-how-can-i-unblock-all-the-files-in-a once I had followed the instructions and ran stream only on my MonoX directory the install carried on smoothly. You can download the streams app here http://technet.microsoft.com/en-us/sysinternals/bb897440.aspx and do the following:

CD in command prompt to where you extracted streams.exe and execute

streams -s -d directory (my directory is c:\inetpub\wwwroot\MonoX2 )

You should see it removing the block data. Once complete I did iisreset /restart and browsed to the site, the install Wizard ran with no problem.



This content has not been rated yet. 
30 Reputation 2 Total posts
denis
3

denis 3/18/2012 9:45:02 PM

This content has not been rated yet. 
7065 Reputation 920 Total posts